Pregunta Error de Xcode "No se pudo encontrar la imagen del disco del desarrollador"


Cuando intento ejecutar una compilación en un dispositivo iOS conectado en Xcode, aparece el siguiente error:

No se pudo encontrar la imagen del disco del desarrollador

Screenshot of error message

Vi que había una versión beta pública para Xcode, así que lo instalé.

Una de las características nuevas es que no necesita tener un Dingus de cuenta de programa de desarrollador para cargar su aplicación directamente en su iPhone.

Sin embargo, en mi iPhone 4s, también hice una actualización beta pública para iOS 8.4, con el problema de que no hay una imagen de disco de desarrollador disponible para ello.

¿Dónde puedo encontrarlo o cómo se puede arreglar?


841
2018-06-09 15:48


origen


Respuestas:


Estoy enfrentando el mismo problema en Xcode 7.3 o una versión anterior de su Xcode y la versión de mi dispositivo es iOS 10 o una versión más reciente de su sistema operativo.

Este error se muestra cuando su Xcode es antiguo y el dispositivo relacionado que está utilizando se actualiza a la última versión. En primer lugar, descargue la última versión de Xcode. No es necesario instalar el último Xcode.

Podemos resolver este problema siguiendo los pasos a continuación:

  • Haga clic derecho sobre Xcode 8 o una versión más nueva de su Xcode, selecciona "Mostrar el contenido del paquete","Contenido","Desarrollador","Plataformas","iPhoneOS.Plataforma","Soporte del dispositivo"
  • Copie la carpeta 10.0 (o superior para una versión posterior).
  • De nuevo en Descubridor seleccionar Aplicaciones de nuevo
  • Haga clic derecho sobre Xcode 7.3 o versión de tu Xcode, ahora seleccione "Mostrar contenido del paquete", "Contenido", "Desarrollador", "Plataformas", "iPhoneOS.Plataforma", "Soporte del dispositivo"
  • Pegue la carpeta 10.0 (o superior para la versión posterior).

Ahora su Xcode tiene una nueva imagen de disco desarrollador. Cierre el buscador ahora y salga de su Xcode. Abra su Xcode y el error desaparecerá. Ahora puede conectar su último dispositivo a versiones antiguas de Xcode.

O

Si no puede descargar la última versión de Xcode, puede obtener la última imagen de disco de desarrollador para su Xcode desde este enlace:

¿Cómo descargar el archivo Xcode DMG o XIP?

Gracias a @Hailei por su respuesta. Para que la gente pueda descargar los últimos DMG.


82
2017-09-30 06:17



Para las personas que tendrían problemas similares en el futuro, tenga en cuenta que este problema está fundamentalmente arraigado en la falta de coincidencia de su versión de iOS y Xcode versión.

Verifique la compatibilidad de iOS y Xcode.


573
2017-11-01 08:34



Personalmente descargué Xcode 6.4 beta y 7.0 beta y estuve muy contento de encontrar la solución buscando "8.4" dentro de la carpeta de aplicaciones de la versión 6.4 beta. Al hacer esto, encontré la carpeta 8.4 (12H4125a) que contiene la imagen de iOS 8.4 y he copiado esta carpeta en la misma ruta de la versión 7.0 beta. La ruta es la siguiente:

/Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport 

Cuando vuelva a abrir Xcode 7 y elija su dispositivo, aparecerá un mensaje de error; solo haga clic en fix issue y eso debería hacerlo!


286
2018-06-23 20:48



Este error ocurre cuando la versión de Xcode es anterior a la del dispositivo.

Por ejemplo, intentar ejecutar una compilación en un dispositivo con iOS 9.3 en Xcode 7.2 da como resultado este error; Could not find Developer Disk Image.

¿Por qué un mensaje de error que realmente describe qué diablos está pasando no se puede proporcionar está más allá de mí (Apple, te estoy mirando).

Actualice la última versión de Xcode a través de App Store o a través de descarga directa para garantizar la interoperabilidad con el hardware iOS conectado.


138
2017-12-16 13:10



Si está utilizando el antiguo Xcode y desea ejecutar dispositivos con una nueva versión de iOS, haga este truco. Esto básicamente hace un enlace simbólico desde el soporte de dispositivos iOS en el nuevo Xcode al viejo Xcode

https://gist.github.com/steipete/d9b44d8e9f341e81414e86d7ff8fb62d

Para Xcode 9.0 beta e iOS 11.0 beta (nombra tu Xcode9.app para Xcode 9 beta y Xcode.app para Xcode 8)

sudo ln -s "/Applications/Xcode9.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/11.0\ \(15A5278f\)" "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport"

113
2018-06-21 09:13



Mi problema fue con Xcode 7 y Xcode 6.4 beta y iOS 8.4 - dispositivo no compatible.

En caso del mismo problema para una mejor comprensión de cómo solucionarlo, haga lo siguiente:

  1. Vaya a /Aplicaciones/Xcode-beta.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport
  2. Ir
    /Aplicaciones/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSup port /
  3. Copie la carpeta iOS 8.4 en otra carpeta

Enter image description here

  1. Reiniciar Xcode

108
2017-07-09 19:37



Si tiene iOS 9.1 en su teléfono, simplemente descárguelo Xcode 7.1 beta en lugar de usar GM.

Vea la respuesta de Apple: No se pudo encontrar la imagen del disco desarrollador para iOS 9.1


75
2017-09-13 01:44



Recibí el mismo mensaje de error (No se pudo encontrar la imagen del disco del desarrollador) después de actualizar mis dispositivos a iOS 9.2, pero olvidé actualizar a Xcode 7.2.

Entonces en mi caso, el arreglar fue fácil: simplemente actualice a Xcode 7.2 a través de Mac App Store.


61
2017-12-12 07:34