Pregunta ¿Qué sucede si el minSdkVersion es más bajo que el targetSdkVersion?


Estoy recibiendo la advertencia:

Attribute minSdkVersion (3) is lower than the project target API level (8)

¿Cómo afectará esto a mi aplicación?


32
2017-10-12 02:22


origen


Respuestas:


Puede ignorar la advertencia de forma segura.

Es una advertencia extraña: significa que está utilizando herramientas para el nivel 8 de la API (Android 2.2 / Froyo), pero apuntando a la API de nivel 3 (Android 1.5 / Cupcake). Esa advertencia siempre aparecerá a menos que esté utilizando el SDK para apuntar a la versión de Android con la que coincide, en este caso, debería apuntar a Android 2.2 con su SDK actual.


25
2017-10-12 02:39



Hago la mayor parte de mi desarrollo con el proyecto establecido en el nivel minSdkVersion. Eso garantiza que no estoy usando API más recientes. Luego, cambio a mi nivel targetSdkVersion antes de publicar la aplicación. El único problema con el que me he encontrado hasta ahora es que el nivel inferior no admite alguna sintaxis de manifiesto que necesite usar en producción. (El nivel 3, por ejemplo, no admite targetSdkVersion). Solo repare el manifiesto después de cambiar al nivel superior.


17
2018-01-03 21:58



Ver también la respuesta de Dianne Hackborn en este hilo: https://groups.google.com/group/android-developers/browse_thread/thread/c468e795daf439f8?pli=1#


3
2018-06-02 22:17