Pregunta Error: no se puede acceder a la metabase de IIS


Después de instalar Visual Studio 2012 y abrir mi solución, recibo una serie de errores en esta forma:

La aplicación web Project Foo está configurada para usar IIS.
  No se puede acceder a la metabase de IIS. No tiene privilegios suficientes para acceder a los sitios web de IIS en su máquina.

Lo recibo para cada una de nuestras aplicaciones web. Cosas que he intentado:

  1. Ejecutando Visual Studio como administrador
  2. Ejecutando aspnet_regiis.exe -ga MyUserName
  3. Ejecutando aspnet_regiis.exe -i

Estas parecen ser soluciones comunes para este problema, pero no he tenido éxito con ellas. ¿Hay algo más que pueda intentar hacer?


762
2017-10-12 13:15


origen


Respuestas:


En Windows 8 Pro:

%systemroot%\inetsrv\config

En Windows 7 y 8.1 y 10

%systemroot%\System32\inetsrv\config 

(Dónde %systemroot% es usualmente C:\Windows)

Navegue a la ubicación adecuada arriba en Windows Explorer. Se le bloqueará el acceso con una ventana emergente que dice:

"No tienes acceso a esta carpeta: haz clic en continuar para tener acceso permanente a esta carpeta"

Haga clic en 'continuar' para esta carpeta y con la carpeta Exportar debajo. Cambié el atajo a "Ejecutar como yo" (un miembro del dominio y los administradores locales) y pude abrir e implementar la solución.


1349
2017-07-04 01:58



Creo que no estás ejecutando Visual Studio con permisos de administrador. Mira eso:

http://bloggingabout.net/blogs/rick/archive/2012/10/04/unable-to-access-the-iis-metabase.aspx

Citar

La solución a esto es simple: inicie su Visual Studio con "Ejecutar como   Administrador ". Puede hacer esto haciendo clic derecho en el acceso directo y   seleccionando "Ejecutar como administrador".


235
2017-10-12 13:19



Creo que encontramos un problema similar en el trabajo. Para nosotros, la solución era ir al Panel de control -> Programas y características -> Activar o desactivar las características de Windows ... dentro de eso, teníamos que seleccionar Servicios de información de Internet -> Herramientas de administración web -> Compatibilidad de administración de IIS 6 -> IIS Metabase y la compatibilidad de configuración de IIS 6. Windows Features dialog showing IIS Metabase option

Pruébalo y avísame si te sirve de ayuda.

Nota: estamos ejecutando IIS 7.5 en Windows 7 usando Visual Studio 2005 y 2010 y haciendo cosas con los servicios web super-old-school (.asmx) ...


47
2017-10-12 13:39



Resolví este problema otorgando permisos de identidad de IIS AppPool al %systemroot%\inetsrv\config


31
2018-05-05 22:06



Si está trabajando en un proyecto que no requiere el uso de IIS, entonces una solución alternativa para abrir el proyecto con este error es simplemente hacer clic con el botón derecho en el proyecto descargado y hacer clic en editar, buscar:

<ProjectExtensions>
    <VisualStudio>
      <FlavorProperties GUID="">
        <WebProjectProperties>
          <UseIIS>True</UseIIS>
        </WebProjectProperties>
      </FlavorProperties>
    </VisualStudio>
  </ProjectExtensions>
</Project>

y establece USEIIS en falso

<UseIIS>False</UseIIS>

vuelva a cargar el proyecto haciendo clic derecho sobre él después de guardar los cambios.


25
2017-08-06 05:57



He tenido dos tipos de problemas diferentes que conducen a este error, y pensé que lo compartiría ...

1. The directory was on an network share and due to UAC restrictions, was 
   unable to be accessed -- even when running as an admin.
2. The directory was on a drive that didn't exist...

Ambos se derivan de una elección desafortunada (imo) por parte de MS para poner las cosas en el directorio Documentos o Mi documento, combinados con mensajes de error realmente pésimos. En los dos casos anteriores, el problema fundamental era que el Archivo de configuración IISExpress va en Mis documentos, y no existía o no se podía acceder.


18
2017-10-04 06:38



Gracias a todos los que respondieron. Como esto estuvo cerrado durante mucho tiempo, no pude proporcionar muchos comentarios, pero eventualmente solucioné mi problema. Intenté muchas de estas otras soluciones y no solucionaron mi problema, pero estoy seguro de que ayudan cuando la causa raíz es diferente.

Mi solución

Resolví este problema al desactivar las características de IIS y .Net Framework en Windows 7 y luego volver a activarlas. Parece que esta reinstalación es lo que solucionó mi problema. Todavía no sé qué causó el problema, pero al menos otro desarrollador de mi equipo tenía el mismo problema.


12
2018-02-05 19:30



Tuve este problema: los síntomas eran los mismos, pero el problema que tuve fue que configuré la carpeta "Mis documentos" para que estuviese en un recurso compartido de red y no se pudo acceder a la acción.

El problema principal era que los archivos de configuración de IIS ubicados en% USERPROFILE% \ Documents no son accesibles. Una vez que cambié la ubicación de la carpeta "Mis documentos" (modifiqué el valor del registro), comenzó a funcionar nuevamente.

Sé que esto puede no ser un escenario común con el que te puedas encontrar, pero lo publiqué aquí porque da los mismos síntomas.


11
2018-02-15 22:15



En una ventana 81, desde un símbolo del sistema de administración, use:

icacls "C:\Windows\System32\inetsrv\config" /t /grant "IIS AppPool\DefaultAppPool":(R)

Luego vuelva a VS, haga clic derecho en el proyecto fallido, elija Recargar.

Crédito a: Descripción general de permisos de IIS7 - ApplicationPoolIdentity


10
2017-09-09 15:12



Puede encontrarse con este problema y tener el mismo problema que yo. Lo "resolví" antes y luego el apagón y la computadora se cayeron, no estoy seguro de por qué registro configuración revertida, pero es el FUENTE de mi problema

  1. Intenté ejecutarlo todo como administrador
  2. Todas las reinstalaciones expresas de IIS / IIS.
  3. Varios "hacks"

Se reduce a tener que arreglar el registro de nuevo.

  1. No era posible que el administrador abriera regedit (Necesita acceder al registro porque el problema no está en la plantilla de administración gpedit.msc)

  2. UnHookExec.inf en el escritorio

Simplemente guarde UnHookExec.inf e instálelo haciendo clic derecho y seleccionando instalar. La instalación del archivo no mostrará ningún cuadro emergente o de aviso. http://www.tweakandtrick.com/2011/04/enable-regedit-registry-editor.html

  1. HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Explorer \ User Shell Folders \ Personal apuntando a la compartición de archivos inexistente. Cambiar eso al camino local resolvió este problema para mí. - Pasi Savolainen 14 de julio de 14 a 8:41

(cambiaron desde \\cs2data\home\stickelt\my documents  a c:\dev  )

Ahora Todo es bueno y Visual Studio abrió una solución con 15 proyectos y se conecta a IIS y no se queja por no poder acceder a sus metadatos

Nunca me había encontrado con esto antes, ya que nadie en el trabajo actual tenía este problema (muchos llevan aquí mucho tiempo, algunos tienen clones de otras máquinas que "funcionaron" y muchos están en otro dominio, etc.)


7
2017-07-01 20:11



Hoy me encontré con esto y solucioné el problema eliminando el IISUrl del archivo de proyecto:

  1. Haga clic derecho en el proyecto
  2. Haga clic en Editar
  3. Eliminar la siguiente línea:

     <IISUrl>http://localhost:xxxxx </IISUrl>
    
  4. Recargar proyecto

  5. Ahora agregue un nuevo directorio virtual de IIS haciendo clic con el botón derecho en Proyecto> Propiedades> Web y seleccionando Usar servidor web IIS local (desmarque Usar IIS Express) y haga clic en el botón Crear directorio virtual.

6
2018-03-16 12:06