Pregunta Xcode 6: el teclado no aparece en el simulador


El teclado no aparece cuando ejecuto el simulador y hago clic en UITextView. ¿Cómo vuelvo a habilitar el teclado?

Solía ​​funcionar, pero ahora no funciona. No sé en qué me podría haber clonado por accidente ... ¡se agradecerán todos los consejos!


591
2018-06-26 00:53


origen


Respuestas:


Tuve el mismo problema. Mi solución fue la siguiente:

  1. Simulador iOS -> Hardware -> Teclado
  2. Desmarque "Conectar el teclado del hardware"

La mía fue revisada porque estaba usando mi teclado Mac, pero si se asegura de que esté desmarcada, siempre aparecerá el teclado del iPhone.


1107
2018-06-30 19:43



Mientras prueba en el simulador beta de ios8, puede alternar entre el "teclado de software" y el "teclado de hardware" con +K.

ACTUALIZAR: Desde iOS Simulator 8.0, el acceso directo es ++K.


310
2017-07-31 07:47



Simulador -> Hardware -> Teclado -> Teclado de alternancia de software debería resolver este problema

Simulator->Hardware->Keyboard->Toggle Software Keyboard


76
2017-10-17 03:32



Esto parece ser un error en iOS 8. Hay dos soluciones a este problema:

  1. Alternar entre el teclado del simulador y el teclado del MacBook con el Mando+K atajo.

  2. Vuelva a conectar el teclado al simulador:

    a. Open Simulator

    segundo. Seleccionar Hardware -> Teclado

    do. Desmarque y luego marque 'Conectar el teclado de hardware'

Screenshot for step 2

O simplemente presione el Cambio + Mando + K atajo


50
2017-11-12 09:59



Para activar / desactivar el teclado del simulador,

⌘ + K (Ctrl + k)

Para deshabilitar la entrada desde su teclado,

Simulador iOS -> Hardware -> Teclado -> Desmarque "Conectar teclado de hardware"


25
2017-11-08 10:53



Puedes usar : ++K para mostrar el teclado en el simulador.


15
2017-10-27 12:37



Sería difícil decir si hay algún problema con su código sin verificarlo, sin embargo, esto me sucede bastante en (Versión 6.0 (6A216f)). Normalmente tengo que restablecer el contenido y la configuración del simulador y / o reiniciar xCode para que funcione nuevamente. Pruébalos y ve si eso resuelve el problema.


11
2018-06-26 00:56



Si el teclado no aparece automáticamente en el simulador, simplemente presione [Command + K]

o Hardware -> Teclado -> Alternar teclado de software 


4
2017-11-15 05:25



Para solucionar el problema, sigue esto:

  1. Salir de Xcode y simulador
  2. Presione 'command + shift + g' ... abrirá el cuadro de diálogo "ir a la carpeta".
  3. escriba "~ / Library / Preferences" en este cuadro de diálogo para ir a su carpeta de preferencias.
  4. Eliminar "com.apple.iphonesimulator.plist" en esta carpeta
  5. Hecho. "Com.apple.iphonesimulator.plist" se regenerará cuando inicie el simulador nuevamente.

Alternativamente, también puede hacer esto con solo un comando.

Terminal abierto y fuego - 1. rm ~ / Library / Preferences / com.apple.iphonesimulator.plist

¡Esto hará el truco en un solo paso! Solo asegúrate de salir de Xcode y del simulador antes de ejecutar esto.


1
2017-10-05 21:47



Manera simple es solo presionar comando + k


0
2017-09-23 07:39