Pregunta Actualice Eclipse con las herramientas de desarrollo de Android v. 23


Actualicé Eclipse con las nuevas herramientas de SDK (versión 23), pero ahora cuando se inicia Eclipse recibo el error:

Este Android SDK requiere Android Developer Toolkit versión 23.0.0 o superior. La versión actual es 22.6.3.v201404151837-1123206. Actualice ADT a la última versión.

No se encontraron actualizaciones con "Buscar actualizaciones". Si intento "Instalar nuevo software", Puedo ver la versión 23, pero no puedo actualizar debido al siguiente error:

Cannot complete the install because of a conflicting dependency.
Software being installed: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
Software currently installed: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
Only one of the following can be installed at once: 
    ADT Package 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.package 22.6.3.v201404151837-1123206)
    ADT Package 23.0.0.1245622 (com.android.ide.eclipse.adt.package 23.0.0.1245622)
Cannot satisfy dependency:
    From: Android Development Tools 23.0.0.1245622 (com.android.ide.eclipse.adt.feature.feature.group 23.0.0.1245622)
    To: com.android.ide.eclipse.adt.package [23.0.0.1245622]
Cannot satisfy dependency:
    From: Android Development Tools 22.6.3.v201404151837-1123206 (com.android.ide.eclipse.adt.feature.group 22.6.3.v201404151837-1123206)
    To: com.android.ide.eclipse.adt.package [22.6.3.v201404151837-1123206]
Cannot satisfy dependency:
    From: ADT Package 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.feature.group 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.feature.group 22.2.0
Cannot satisfy dependency:
    From: Android Developer Tools 22.2.1.v201309180102-833290 (com.android.ide.eclipse.adt.package.product 22.2.1.v201309180102-833290)
    To: com.android.ide.eclipse.adt.package.feature.group [22.2.1.v201309180102-833290]

Después de descargar el último ADT del sitio web, parece que hay otro problema.

Con SDK Tools rev. 23 proguard no está instalado, la carpeta SDK dir/tools/proguard falta, y faltan otras herramientas. Esta versión contiene varios errores.


581
2018-06-26 18:21


origen


Respuestas:


Google ha lanzado ADT v23.0.2. Esto resolvió muchos problemas de la versión anterior de ADT 23.

Paso a paso:

  • Menú Ayuda → Instalar nuevo software ...
  • Para "Trabajar con", selecciona la fuente de Android https://dl-ssl.google.com/android/eclipse Work with Android source
  • Marque ADT v23.0 para la instalación, luego haga clic en "Siguiente"
  • Eclipse mostrará "Instalar página de reparación" ya que hay conflicto con la versión anterior. (De lo contrario, consulte a continuación.) Seleccione "Actualizar mi instalación para que sea compatible con los elementos que se están instalando" para desinstalar la versión anterior e instalar la nueva. Después de eso, proceda con los pasos habituales.

Install remediation page

Nota: Cuando instalé la nueva versión de ADT, no incluí la nueva versión del paquete "Herramientas nativas de desarrollo de Android". En su lugar, instalé primero el resto de paquetes y luego instalé "Herramientas nativas de desarrollo de Android". Por alguna razón, si intento instalar todos los paquetes nuevos, incluidas las "Herramientas nativas de desarrollo de Android", la instalación falla.

Si no hay una "página de remediación", la única forma de eliminar el complemento ADT de Eclipse es ir al menú Ayuda → Acerca de Eclipse → Detalles de instalación y desinstalar desde allí. Pero existe el riesgo de desinstalar Eclipse.


190
2018-06-26 18:33



Respuesta de Google:

Este es un error de empaque. Todo el archivo proguard falta. Tendremos una actualización lo antes posible, pero hasta entonces solo copiemos desde una versión anterior de las herramientas:

y copie sobre los siguientes archivos:

  • herramientas / hprof-conv
  • herramientas / soporte / anotaciones.jar
  • herramientas / proguard

Entonces, al final, si comenzaste desde una nueva copia ADT a mano, los archivos :)

Editar: con la última versión de ADT, el paquete debería funcionar ahora con la actualización automática, por lo que instala estas nuevas versiones:

No intente actualizar desde la versión anterior porque no funciona en absoluto. Si tiene problemas con zipalign, ahora está en las herramientas de compilación y no en las herramientas / para que pueda hacer un enlace simbólico o simplemente copiarlo en la carpeta esperada.


113
2018-06-27 15:35



Ninguna de las otras respuestas funcionó para mí usando el paquete ADT publicado en developer.android.com.

Terminé descargando la última versión de Eclipse (no el paquete ADT) y luego instalar el complemento ADT a través del menú Ayuda → Instalar nuevo software → entrar https://dl-ssl.google.com/android/eclipse (mencionado por @RED_).

También tuve que actualizar mi espacio de trabajo para apuntar a mi área de trabajo anterior, y la mayoría de las cosas parecían restauradas.

En una nota al margen: este parece ser un buen momento para migrar a Android Studio ...


53
2018-06-26 20:56



NOTA: utilice este enfoque con precaución ya que podría romper su instalación de Eclipse  (ver comentarios).

Esto podría ayudarlo si instaló el complemento ADT a mano. Pero si está utilizando la versión de Eclipse del Eclipse ADT Bundle los siguientes pasos podrían romper su instalación de Eclipse, ¡y es posible que no pueda volver a utilizar Eclipse!

Ir

Menú Ayuda → Acerca de Eclipse SDK → Detalles de instalación.

Ahora verás todo 22.0 versiones y luego haga clic Uninstall botón en la parte inferior.

Después de la desinstalación goto:

Menú Ayuda → Instalar nuevo software → entrar http://dl-ssl.google.com/android/eclipse/

Luego instala todas las cosas, y ahora está listo.


52
2018-06-27 09:41



Estaba actualizando mi servidor de compilación hoy y encontré el mismo problema. Se ha informado aquí: https://code.google.com/p/android/issues/detail?id=72419

La solución está en progreso y el trabajo según el administrador del proyecto es:

Espere una versión actualizada dentro de uno o dos días. Hasta entonces, su solución es descargar una de

http://dl.google.com/android/android-sdk_r22.6.2-linux.tgz

http://dl.google.com/android/android-sdk_r22.6.2-windows.zip

http://dl.google.com/android/android-sdk_r22.6.2-macosx.zip

y copie sobre los siguientes archivos:

    tools/hprof-conv
    tools/support/annotations.jar
    tools/proguard

[editar] zipalign también me falta, compruebe si necesita copiar esto también


18
2018-06-27 16:45



Esto funciona para mi :)

Si por alguna razón instaló una vista previa de ADT y necesita volver al establo actual, no puede usar el diálogo para instalar el "nuevo" software, ya que lo que desea es realmente uno más antiguo. En lugar de hacer esto:

  • Abrir Ayuda> Acerca de Eclipse ... en Windows o Linux. En Mac, utiliza el menú de la aplicación> Acerca de ...
  • Haga clic en el botón "Detalles de instalación".
  • Seleccione la pestaña "Historial de instalación".
  • Seleccione una de las configuraciones anteriores.
  • Haga clic en el botón "Revertir" en la parte inferior.

enter image description here


17
2018-06-29 20:56



es lo que dicen sobre esto:

Bien, muchachos, perdón por todos estos problemas, y nos disculpamos por los lanzamientos desordenados. Aquí está el resumen:

Comenzando con ADT bundle 23.0.2, debería poder actualizar a versiones futuras de ADT.

Fuente:  https://code.google.com/p/android/issues/detail?id=72912


16
2017-07-16 10:00



He hecho lo siguiente para resolver un problema.

  1. Ir http://developer.android.com/sdk/installing/installing-adt.html y descargue el último archivo ZIP ADT (en la parte inferior de la página).

  2. Ir a Eclipse → menú Ayuda → Acerca de Eclipse → Detalles de instalación

  3. Borrar Android DDM, Herramientas de desarrollo de Android, Visor de jerarquía, Herramientas de desarrollo nativo, TraceView, etc., versión 22.X.

  4. Menú Ayuda * → Instalar nuevo software → Añadir → Archivo → * Seleccione el archivo ZIP descargado en el paso 1.

  5. Seleccione toda la última versión de las 23 que he eliminado en el paso 3 y acepte el acuerdo de licencia.

Reinicie Eclipse, y soluciona mi problema.


15
2018-06-26 18:59



Solo ayudado:

  1. Instalación de Fresh Eclipse (http://www.eclipse.org/downloads/packages/eclipse-ide-java-developers/lunar)
  2. Ayuda -> Instalar nuevo software -> https://dl-ssl.google.com/android/eclipse/

9
2018-06-27 15:01



Si instala un nuevo Eclipse versión funcionará. Esto es lo que hice:

  1. Instalado la nueva versión de Eclipse, Luna
  2. Hizo una copia de seguridad del espacio de trabajo actual.
  3. Ejecuté el nuevo Eclipse, Luna y actualicé el espacio de trabajo
  4. Instalado el Complemento ADT (Ayuda -> Instalar nuevo software)
  5. Eclipse reiniciado
  6. Hecho

8
2018-06-27 09:32