Pregunta Cómo instalar Automapper para .net 3.5


Me gustaría utilizar Automapper con .net 3.5.

He encontrado una sucursal en Git Hub, gracias a esta publicación por el creador Jimmy Bogard:

... pero no puedo entender cómo instalarlo.

La versión de .net 4 se instala usando nuget 

¿Alguien sabe cómo instalo la versión .net 3.5?

¿Simplemente lo construyo yo mismo y lo uso como mi propio proyecto?

Si es así, ¿cómo lo construyo? ¿Necesito crear un paquete NuGet?


15
2017-11-17 14:03


origen


Respuestas:


https://github.com/downloads/AutoMapper/AutoMapper/AutoMapper.dll

Este .dll es la versión 1.1 que según el sitio es la última versión .net 3.5. Simplemente haz referencia en tu proyecto y debería funcionar.


19
2017-11-17 14:14



No es necesario construir la fuente usted mismo. AutoMapper 1.1 está disponible en NuGet en http://nuget.org/packages/AutoMapper/1.1.0.118

El comando de la consola PM es PM> Install-Package AutoMapper -Version 1.1.0.118


7
2018-01-14 17:13



¿Simplemente lo construyo yo mismo y lo uso como mi propio proyecto?

Sí, aunque no necesita incluir el proyecto AutoMapper en su solución;

Si es así, ¿cómo lo construyo? ¿Necesito crear un paquete NuGet? 

El paquete NuGet no es obligatorio.

Debe descargar la fuente de AutoMapper para .net3.5 de aquí

Una vez descargado, puede abrir el sln archivo debajo del src carpeta y crea el proyecto AutoMapper (solo ese proyecto lo hará)

Luego puede copiar el dll producido (es decir, encontrado en src\AutoMapper\bin\Debug) a su carpeta de lib compartida y referencia eso.


5
2017-11-17 14:11