Pregunta PHP-FPM y Nginx: 502 Bad Gateway


Configuración

  • Ubuntu Server 11.10 64 bit
  • Amazon AWS, Ec2, alojado en la nube
  • instancia de t1.micro

Antes de escribir algo más, me gustaría decir que he verificado ambos nginx 502 bad gateway y Nginx + PHP-FPM 502 Mala puerta de enlace hilos, que lamentablemente no me han ayudado en este sentido.

El problema parece ser bastante común: una configuración incorrecta de nginx o php-fpm puede llevar a una 502 Bad Gateway error, que es algo de lo que no he podido deshacerme. Tenga en cuenta que esto aparece incluso cuando voy a la raíz de mi dominio, sin especificar ningún directorio en particular.

Estoy ejecutando un servidor web Amazon EC2, con el puerto 9000 habilitado, el puerto 80 abierto, etc.

La pregunta en particular es, ¿cómo puedo deshacerme de este desagradable error? O, mejor aún, ¿cómo puedo obtener php5-fpm a en realidad trabajo.

Lo que he intentado hasta ahora

La mayoría de las veces la edición consistente de archivos de configuración, notablemente php-fpm.conf y nginx.conf.

yo.  php-fpm.conf

He agregado lo siguiente, que no ha ayudado mucho:

;;;;;;;;;;;;;
; Fpm Start ;
;;;;;;;;;;;;;

;pm.start_servers = 20
;pm.min_spare_servers = 5
;pm.max_spare_servers = 35

Ahora, después intenté incluir mis archivos de configuración:

include=/etc/php5/fpm/*.conf

Lo cual solo me fastidió aún más.

Configuración completa

;;;;;;;;;;;;;;;;;;;;;
; FPM Configuration ;
;;;;;;;;;;;;;;;;;;;;;

; All relative paths in this configuration file are relative to PHP's install
; prefix (/usr). This prefix can be dynamicaly changed by using the
; '-p' argument from the command line.

; Include one or more files. If glob(3) exists, it is used to include a bunch of
; files from a glob(3) pattern. This directive can be used everywhere in the
; file.
; Relative path can also be used. They will be prefixed by:
;  - the global prefix if it's been set (-p arguement)
;  - /usr otherwise
;include=/etc/php5/fpm/*.conf

;;;;;;;;;;;;;;;;;;
; Global Options ;
;;;;;;;;;;;;;;;;;;

[global]
; Pid file
; Note: the default prefix is /var
; Default Value: none
pid = /var/run/php5-fpm.pid

; Error log file
; Note: the default prefix is /var
; Default Value: log/php-fpm.log
error_log = /var/log/php5-fpm.log

; Log level
; Possible Values: alert, error, warning, notice, debug
; Default Value: notice
log_level = notice

; If this number of child processes exit with SIGSEGV or SIGBUS within the time
; interval set by emergency_restart_interval then FPM will restart. A value
; of '0' means 'Off'.
; Default Value: 0
;emergency_restart_threshold = 0

; Interval of time used by emergency_restart_interval to determine when 
; a graceful restart will be initiated.  This can be useful to work around
; accidental corruptions in an accelerator's shared memory.
; Available Units: s(econds), m(inutes), h(ours), or d(ays)
; Default Unit: seconds
; Default Value: 0
emergency_restart_interval = 0

; Time limit for child processes to wait for a reaction on signals from master.
; Available units: s(econds), m(inutes), h(ours), or d(ays)
; Default Unit: seconds
; Default Value: 0
;process_control_timeout = 0

; Send FPM to background. Set to 'no' to keep FPM in foreground for debugging.
; Default Value: yes
daemonize = no

;;;;;;;;;;;;;
; Fpm Start ;
;;;;;;;;;;;;;

;pm.start_servers = 20
;pm.min_spare_servers = 5
;pm.max_spare_servers = 35

;;;;;;;;;;;;;;;;;;;;
; Pool Definitions ; 
;;;;;;;;;;;;;;;;;;;;

; Multiple pools of child processes may be started with different listening
; ports and different management options.  The name of the pool will be
; used in logs and stats. There is no limitation on the number of pools which
; FPM can handle. Your system will tell you anyway :)

; To configure the pools it is recommended to have one .conf file per
; pool in the following directory:
include=/etc/php5/fpm/pool.d/*.conf

ii. nginx.conf

Honestamente, esta configuración es un puñado de algunos sitios web que he visitado, pero puedo decirles que antes de este 502 negocio de Bad Gateway, el servidor funcionaba bien (sin PHP funcionando. Período).

El problema radica principalmente en el hecho de que algo es terriblemente, terriblemente mal. Y ahora, cuando intento hacer una service php5-fpm restart, se cuelga en lo que supongo que es un bucle infinito o algo así, que ni siquiera puedo CTRL-do fuera de.

Configuración completa

user www-data;
worker_processes 1;
pid /var/run/nginx.pid;

events {
    worker_connections 64;
    # multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush off;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;

    server {
        listen 80;
        server_name ec2-xx-xx-xx-xx.compute-x.amazonaws.com;

        location ~ ^(.+\.php)(.*)$ {
            root   /home/wayvac/public;
            fastcgi_pass   unix:/var/run/php5-fpm.pid;  
            #fastcgi_pass   127.0.0.1:9000; #Un-comment this and comment "fastcgi_pass   unix:/var/run/php-fpm/php-fpm.sock;" if you are not using php-fpm.
            fastcgi_index  index.php;
            set $document_root2 $document_root;
            if ($document_root2 ~ "^(.*\\\\).*?[\\\\|\/]\.\.\/(.*)$") { set $document_root2 $1$2; }
            if ($document_root2 ~ "^(.*\\\\).*?[\\\\|\/]\.\.\/(.*)$") { set $document_root2 $1$2; }
            if ($document_root2 ~ "^(.*\\\\).*?[\\\\|\/]\.\.\/(.*)$") { set $document_root2 $1$2; }
            if ($document_root2 ~ "^(.*\\\\).*?[\\\\|\/]\.\.\/(.*)$") { set $document_root2 $1$2; }
            if ($document_root2 ~ "^(.*\\\\).*?[\\\\|\/]\.\.\/(.*)$") { set $document_root2 $1$2; }
            fastcgi_split_path_info ^(.+\.php)(.*)$;
            fastcgi_param   SCRIPT_FILENAME $document_root2$fastcgi_script_name;
            fastcgi_param   PATH_INFO   $fastcgi_path_info;
            fastcgi_param   PATH_TRANSLATED $document_root2$fastcgi_path_info;
            include fastcgi_params;
            fastcgi_param  DOCUMENT_ROOT      $document_root2;
        }       

        access_log /var/log/nginx/access.log;
        error_log /var/log/nginx/error.log;

        location / {
            root /home/wayvac/public;   
            index index.html index.htm index.php;
        }

        location ~* \.(?:ico|css|js|gif|jpe?g|png)$ {
            # Some basic cache-control for static files to be sent to the browser
            expires max;
            add_header Pragma public;
            add_header Cache-Control "public, must-revalidate, proxy-revalidate";
        }

        #include drop.conf;
        #include php.conf;
    }
}

75
2018-04-04 01:50


origen


Respuestas:


Si alguien encuentra esta página al encontrar el mismo problema que yo tuve, encontré la respuesta aquí: http://www.howtoforge.com/installing-nginx-with-php5-and-php-fpm-and-mysql-support-lemp-on-ubuntu-12.04-lts

Para aquellos de ustedes que no pueden molestarse en hacer clic y resolverlo por sí mismos ...;)

La condición:

El servidor Ubuntu o Debian con NGINX y PHP 5.3 funciona bien, pero actualizar PHP a 5.4 da 502 errores de puerta de enlace incorrecta. Buscando servicios que se ejecutan en el puerto 9000 (normalmente ejecutando netstat -lp o similar) no devuelve nada.

La solución:

Abierto /etc/php5/fpm/pool.d/www.conf y anote el parámetro 'escuchar' (en mi caso /var/run/php5-fpm.sock)

; The address on which to accept FastCGI requests.
; Valid syntaxes are:
;   'ip.add.re.ss:port'    - to listen on a TCP socket to a specific address on
;                            a specific port;
;   'port'                 - to listen on a TCP socket to all addresses on a
;                            specific port;
;   '/path/to/unix/socket' - to listen on a unix socket.
; Note: This value is mandatory.
listen = /var/run/php5-fpm.sock

y reemplace la variable fastcgi_pass en su vhost con la ubicación que acaba de anotar.

Entonces esta configuración de ejemplo de symfony2 (tomada desde aquí: http://wiki.nginx.org/Symfony)

  # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
  location ~ ^/(app|app_dev)\.php(/|$) {
    fastcgi_pass   127.0.0.1:9000;
    fastcgi_split_path_info ^(.+\.php)(/.*)$;
    include fastcgi_params;
    fastcgi_param  SCRIPT_FILENAME    $document_root$fastcgi_script_name;
    fastcgi_param  HTTPS              off;
  }

se convierte en esto:

  # pass the PHP scripts to FastCGI server at /var/run/php5-fpm.sock
  location ~ ^/(app|app_dev)\.php(/|$) {
    fastcgi_pass unix:/var/run/php5-fpm.sock;
    fastcgi_split_path_info ^(.+\.php)(/.*)$;
    include fastcgi_params;
    fastcgi_param  SCRIPT_FILENAME    $document_root$fastcgi_script_name;
    fastcgi_param  HTTPS              off;
  }

Luego reinicie nginx:

sudo /etc/init.d/nginx restart

Nota: reemplazar ~ ^/(app|app_dev)\.php(/|$) { con ~ ^/index\.php(/|$) { si no estás en SF2 **

Espero que esto le ahorre a alguien un poco de tiempo :)

Editar

Por supuesto, podrías cambiar el listen = /var/run/php5-fpm.sock a listen = 127.0.0.1:9000 en /etc/php5/fpm/pool.d/www.conf luego reinicie php5-fpm (lo que le evitaría tener que cambiar sus fantasmas), pero debe suponer que cambiaron php5-fpm para ejecutar a través de un socket en lugar de escuchar en el puerto 9000 por algún motivo.

Edit2

Si sigues experimentando el error 502, mira esta respuesta: Error de nginx conectado a php5-fpm.sock failed (13: Permiso denegado)


151
2018-01-28 10:40



Intenta configurar estos valores, resuelve el problema en fast-cgi

fastcgi_buffer_size 16k;
fastcgi_buffers 4 16k;

28
2018-05-22 06:51



Hice todos estos ajustes similares, pero de vez en cuando recibía 501/502 errores (a diario).

Esta es mi configuración en /etc/php5/fpm/pool.d/www.conf para evitar 501 y 502 errores nginx ... El servidor tiene 16Gb de RAM. Esta configuración es para un servidor de RAM de 8 Gb así que ...

sudo nano /etc/php5/fpm/pool.d/www.conf

luego configure los siguientes valores para

pm.max_children = 70
pm.start_servers = 20
pm.min_spare_servers = 20
pm.max_spare_servers = 35
pm.max_requests = 500

Después de esto, reinicie php-fpm

sudo service php-fpm restart

10
2017-12-22 00:58



Si se encontró con el problema después de actualizar php-fpm como yo, intente esto: abra /etc/php5/fpm/pool.d/www.conf Descomenta las siguientes líneas:

listen.owner = www-data
listen.group = www-data
listen.mode = 0666

luego reinicie php-fpm.


4
2018-01-30 05:25



No olvides eso php-fpm es un servicio Después de instalarlo, asegúrese de iniciarlo:

# service php-fpm start
# chkconfig php-fpm on

3
2018-06-11 06:45



Para cualquier otra persona que esté luchando por llegar al fondo de esto, traté de ajustar los tiempos de espera según lo sugerido, ya que no quería dejar de usar los zócalos de Unix ... después de mucha resolución de problemas y no mucho más, descubrí que este problema estaba siendo causado por la extensión de APC que habilité en php-fpm hace unos meses. La desactivación de esta extensión resolvió los errores intermitentes 502, la manera más fácil de hacerlo fue comentando la siguiente línea:

;extension = apc.so

¡Esto hizo el truco para mí!


2
2018-06-23 18:40



El puerto se cambió a 9001 en 5.4, simplemente cambiando el puerto de 9000 a 9001 en nginx conf y en la configuración de php-fpm funcionó para mí.


1
2017-08-04 07:07