Pregunta WordPress me está dando la página 404 no encontrada para todas las páginas excepto la página de inicio


De repente, voy a mi sitio web de WordPress y todas las páginas me dan una página de 404 páginas no encontradas. Supongo que el problema radica en la estructura del enlace permanente, que podría jurar que no toqué. La configuración del enlace permanente está en "mes y nombre".

Investigué instancias similares de este problema en línea y mucho tiene que ver con el .htaccess ¿archivo? Traté de encontrarlo, pero no puedo. Tal vez se borró de alguna manera? ¿Dónde se supone que se encuentra?

Cualquier sugerencia será de ayuda

y por supuesto puedo ver archivos ocultos.


75
2018-03-03 15:07


origen


Respuestas:


.htaccess es un archivo oculto, por lo que debe establecer todos los archivos como visibles en su ftp.

Le sugiero que devuelva su estructura de enlace permanente al valor predeterminado (? P = ID) para asegurarse de que .htaccess es el problema.

Después de eso, simplemente podría establecer la estructura de "mes y nombre" nuevamente, y ver si funciona.

PD: ¿Has actualizado a 3.1? He visto algunas personas con problemas de complementos en este caso.


74
2018-03-03 15:18



Reparar ese problema es muy simple si usaba enlaces permanentes distintos del default como Day and name, Month and name, Numeric, Post name o Custom Structure, solo necesitas

Inicie sesión en su área de administración: Settings > Permalinks que debería ser: http://yoursite.com/wp-admin/options-permalink.php 

Escoger Default ajuste permanente, luego guarde los cambios

Entonces tú puedes devolverlo nuevamente a su otra opción de enlace permanente anterior o mantenlo como default como quieras

Tenga en cuenta que este problema puede ocurrir cuando mueve su sitio de un dominio o ubicación a otro.


34
2017-09-27 19:59



Básicamente, el archivo .htaccess debería existir y el httpd.conf debería ser correcto.

En mi caso, cambié el archivo /etc/httpd/conf/httpd.conf en la sección:

<Directory "/var/www/html">

La línea cambiada es:

AllowOverride None

a

AllowOverride All

Y reinicie el servidor web.


25
2017-09-09 04:52



Si el comportamiento predeterminado (example.com/?p=42) está funcionando, usted debe:

  • Cambie a su estilo de enlace permanente preferido: Admin: Settings > Paramalinksy haz clic en Guardar. En algún momento soluciona el problema. Si no fuera así:
  • Verificar que el archivo /path/to/wordpress/.htaccess había sido cambiado y ahora incluye la línea RewriteEngine On. Si no es así, es un problema de permisos de Wordpress.
  • Verifique que el módulo 'reescribir' esté cargado: cree un archivo PHP con

    <?php
      phpinfo()
    ?>
    

    en él, ábrelo en el navegador y busca mod_rewrite. Debe estar en la sección 'Módulos cargados'. Si no es así, habilítela: observe su valor predeterminado de apache index.html archivo para más detalles - en Ubuntu, lo haces con el ayudante a2enmod.

  • Verifique que el servidor Apache esté mirando el .htaccess archivo. abierto httpd.conf - o es la alternativa de Ubuntu, /etc/apache2/apache2.conf. En ella, debes tener algo como

    <Directory /path/to/wordpress>
      Options Indexes FollowSymLinks
      AllowOverride All
      Require all granted
    </Directory>
    
  • Después de realizar estos cambios, no olvide reiniciar su servidor apache. sudo service apache2 restart


12
2018-01-30 02:06



Dentro de la interfaz de administración de WordPress haga lo siguiente:

  1. Ir a configuración de administrador

  2. Haga clic en enlace permanente y seleccione el nombre de la publicación en el botón de opción.

  3. Desplázate hacia abajo y verás .htaccess código aquí como.

    <IfModule mod_rewrite.c>
        RewriteRule ^index\.php$ - [L]
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule . /wordpress/index.php [L]
    </IfModule> 
    
  4. Copia el código y pega el .htaccess archivo.

10
2018-03-14 10:24



Es fácil solucionar el problema simplemente siga algunos pasos a continuación , Si accede para iniciar sesión en su tablero de administración simplemente

Go to Settings » Permalinks, and simply click on Save Changes button.

enter image description here

Esto actualizará la configuración de enlaces permanentes y las reglas de reescritura. En la mayoría de los casos, esta solución corrige el error 404 de WordPress. Sin embargo, si no funciona para usted, entonces probablemente necesite actualizar su archivo .htaccess manualmente.

Ingrese a su servidor usando FTP, y modifique el .htaccess archivo que se encuentra en la misma ubicación donde se encuentran carpetas como / wp-content / y / wp-includes /, simplemente coloque los códigos debajo de su .htaccess

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

Espero que esto solucione el problema.


9
2017-11-30 05:10



Este error está causando debido a la deshabilitación del mod de reescritura en el documento httpd.conf de apache, simplemente quítelo y disfrute de los enlaces permanentes seo friendly.


6
2018-04-05 22:34



  • Verifique que el directorio en .htaccess sea el correcto
  • Compruebe los campos "siteurl" y "home" son los correctos

3
2018-03-04 07:07



Si todo esto no funciona, su .htaccess es correcto y el truco de permalinks no funcionó, puede que no haya habilitado su mod rewite apache2.

Ejecuté esto y mi problema fue resuelto:

 sudo a2enmod rewrite 

3
2018-02-20 18:06