Pregunta Falló la instalación de la aplicación: no se pudo escribir en el dispositivo


en Xcode 6.3 Obtuve este error al intentar ejecutar un proyecto de iOS escrito rápidamente en un dispositivo real.

Error al instalar la aplicación

no pudo escribir en el dispositivo.

Intenté limpiar el proyecto y ejecutarlo nuevamente, pero existe el mismo error.

¿Cómo soluciono este error?

Gracias


74
2018-06-23 12:20


origen


Respuestas:


eliminar la aplicación en el dispositivo y ejecutar el proyecto de nuevo funciona para mí


43
2018-06-21 09:17



Hice una limpieza e instalé mi aplicación con éxito.

Producto-> Limpio (Shift-Cmd-K)


30
2018-02-23 09:35



Apagué el dispositivo y lo volví a encender después de lo cual no obtuve ese error.


15
2017-10-14 07:20



Tengo este problema dos veces en una semana en dispositivos completos diferentes.

A un dispositivo no le quedaba más espacio de almacenamiento, luego de eliminar algunas aplicaciones, el proyecto se instaló perfectamente.

El otro dispositivo fue reparado después de reiniciar el dispositivo


11
2018-04-08 07:39



De acuerdo, hay algunas cosas que debería considerar que podrían guiarnos hacia el problema, verifique y publique las respuestas:

  1. ¿tu proyecto está usando capacidades? están configurados correctamente (deberían ser todos verdes)
  2. ¿Intentó con un proyecto diferente (algo realmente simple)?
  3. ¿puedes instalar aplicaciones desde App Store?
  4. revisaste la cantidad de espacio libre que queda en el dispositivo?

si no, otra sugerencia utilizará el punto de interrupción de excepción, hay alguien que publicó una explicación sobre cómo configurarlo, hacerlo y publicar los registros

Error al instalar la aplicación

Espero que te ayude


10
2017-08-18 16:09



Si estás usando un cuenta de desarrollador gratis Es posible que deba desinstalar algunas otras aplicaciones que haya firmado.


10
2017-10-09 03:04



Para mí fue el perfil de aprovisionamiento: utilicé la distribución en lugar del desarrollo


7
2017-10-20 16:24



Para mí, lo siguiente no funcionó en iOS 11 beta 10, XCode 9 beta 6:

  • Reiniciar el dispositivo
  • Eliminar la aplicación del dispositivo
  • No hay enlaces simbólicos en el proyecto
  • Había mucho espacio de almacenamiento disponible

Suprimido Derived Data y voilá, funcionó de nuevo


6
2017-09-07 15:25



Mi problema era un marco incrustado.

Vaya a "Crear fases" -> "Incrustar marcos" -> Marque "Copiar solo al instalar", y eliminó el problema por mí.

enter image description here


5
2017-09-29 18:13



en mi proyecto, este problema ocurrió porque había una carpeta con un enlace simbólico. Eliminé esa carpeta y funcionó correctamente.


4
2018-03-28 14:51



Tuve un enlace simbólico en mi proyecto a un archivo fuera del proyecto. Cuando borré este enlace simbólico, la instalación funcionó bien.


3
2018-03-23 15:30