Pregunta Xcode: no se pudieron ubicar los archivos de soporte del dispositivo


Como estoy tratando de ejecutar mi aplicación desde la última actualización Xcode 8 para mi Iphone 4 que se está ejecutando iOS 7.1.2 

Lanza debajo de error,

iOS 7.1.2

Y esta es mi Xcode versión,

Xcode 8

¿Alguien se ha enfrentado a este problema antes? ¡En espera de sus sugerencias!


74
2017-09-23 07:33


origen


Respuestas:


Tuve un problema similar porque la versión de la tienda de aplicaciones no tenía compatibilidad con iOS 10.1 en Xcode 8 y todavía no han lanzado una actualización. Esto causó el problema "Xcode: no se pudo encontrar el archivo de soporte del dispositivo". Puede descargar la última actualización https://developer.apple.com/download/ y es más actual y es compatible con iOS 10.1 (14B72c).


50
2017-10-24 22:14



En realidad, hay una manera. Solo necesita copiar la carpeta DeviceSupport para iOS 7.1 de Xcode anterior a la nueva. Está ubicado en:

/Aplicaciones/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/7.1

Si ya no tiene los archivos 7.1, puede descargar una versión anterior de XCode en https://developer.apple.com/download/more/, extráigalo y luego copie estos archivos en la ruta siguiente

/Aplicaciones/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

Crédito 


45
2018-03-07 10:25



Necesita soporte de dispositivo de la versión anterior de Xcode (7.3.1).

Yo recomendaría usar esta herramienta: https://github.com/KrauseFx/xcode-install

Cuando instale Xcode 7, debe vincular los archivos de soporte a Xcode 8:

sudo ln -s /Applications/Xcode-7.3.1.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/7.* \
/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/

22
2017-09-23 08:17



Este error se muestra cuando su XCode es antiguo y el dispositivo relacionado que está utilizando se actualiza a la última versión. Antes que nada, instale la última versión de Xcode.

Podemos resolver este problema siguiendo los pasos a continuación:

  1. Abrir Buscador seleccione Aplicaciones
  2. Haga clic derecho en Xcode 8, seleccione "Mostrar contenido del paquete", "Contenido", "Desarrollador", "Plataformas", "iPhoneOS.Plataforma", "Soporte del dispositivo"
  3. Copie la carpeta 10.0 (o superior para una versión posterior).
  4. De vuelta en Finder selecciona Aplicaciones de nuevo Haga clic derecho en Xcode 7.3, seleccione "Mostrar contenido del paquete", "Contenido", "Desarrollador", "Plataformas", "iPhoneOS.Plataforma", "Soporte del dispositivo" Pega la carpeta 10.0

Si todo funcionó correctamente, su XCode tiene una nueva imagen de disco desarrollador. Cierre el buscador ahora y salga de su XCode. Abra su Xcode y el error desaparecerá. Ahora puede conectar su último dispositivo a versiones antiguas de Xcode.

Gracias


9
2017-07-03 06:25



Tener el mismo problema exacto con iOS 10.3 y Xcode 8.2.1. No voy a descargar la nueva versión beta de Xcode solo para solucionar esto. Vamos Apple!

Para cualquiera que lea esto, tienes que ir a https://developer.apple.com/download/ y obtenga la última versión, que incluso podría ser la versión beta, si la versión estable no funciona.

En el futuro, sabré que si actualiza iOS en sus dispositivos, puede romper la versión de Xcode / iOS, así que actualícese sabiamente si desea seguir probándola sin pasar por los límites que crea Apple.


7
2018-02-15 15:55



Si tiene XCode 8.1 e iOS 10.2, actualice XCode manualmente a 8.2.1. Por alguna razón, App Store no ofreció esta actualización.


6
2018-01-04 14:21



  1. Descargar y montar http://adcdownload.apple.com/Developer_Tools/Xcode_7.3.1/Xcode_7.3.1.dmg Fui vagado por primera vez si se pudiera montar directamente a través de hdiutil attach y parece que podría pero no para las cuentas de todos.

  2. Abierto para ver su contenido y copia Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/7.1 a la misma ruta en el directorio de la aplicación Xcode.

  3. Reiniciar Xcode

1
2018-06-11 15:38



Mismo problema, vaya a App Store y actualice Xcode


1
2018-04-13 15:29



En caso de obtener "No se pudieron encontrar los archivos de soporte del dispositivo" después de que la versión de iOS de su dispositivo se haya actualizado y su Xcode todavía sea una versión anterior, simplemente presione el SDK anterior con el nuevo nombre y reinicie Xcode. Abre tu terminal y haz lo siguiente:

$ cd /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/DeviceSupport/
$ cp -rpv  10.3.1\ \(14E8301\)/ 11.2.1

Reinicie Xcode y probablemente funcione.


0
2018-01-12 12:39