Pregunta Intro., Retroceso y las teclas de navegación no responden en Visual Studio 2010 con Powertools / Resharper


Tengo este problema tan molesto que en Razor Views, el Enter, Backspace y las teclas de navegación con frecuencia no responden. Tengo que reiniciar VS para volver a la normalidad. ¿Me estoy perdiendo de algo?


73
2017-08-31 18:43


origen


Respuestas:


Tuve el mismo problema y lo resolví guardando el archivo de la navaja (Ctrl + S). Una vez que hice esto, pude usar las teclas Intro, Retroceso y Navegación nuevamente.

Creo que Alt + Enter también puede funcionar.

No suelo entrar en este estado y la solución anterior no resuelve el problema subyacente. Creo que puede tener algo que ver con ReSharper, pero no he descubierto si esta suposición es cierta o no.

Hay varias páginas que discuten este tipo de problema: Enlace 1 Enlace 2 Enlace 3


93
2017-09-01 05:51



Intente eliminar la configuración oculta '.suo' de la carpeta de la solución.

Sé que este hilo fue creado hace un tiempo, pero puede ser un consejo útil para alguien.


26
2017-07-11 10:40



Esto me estaba pasando en VS 2010, a pesar de no usar R #. Después de hurgar en esos enlaces que @Ryan Spears puso en su publicación, me encontré con una solución permanente Fuente. (Tenga en cuenta que la solución de @Maffelu funcionó para mí, pero puede volver atrás si presiono accidentalmente Alt + Mayús Izquierda).

Esto también es extraño porque Left Alt + Shift no parece cambiarlo, así que tienes que ir a la fuente: un enlace de clave enterrado en el Panel de control de Windows:

Panel de control > Región e idioma > Teclados e idiomas > Cambiar teclados > Configuración de clave avanzada > Cambiar la secuencia clave > Seleccione "No asignado" para ambos Cambiar el idioma de entrada y cambiar el diseño del teclado.

enter image description here


14
2018-05-30 12:16



No uso ReSharper y esto todavía sucedió. Prensado Control + Tab dos veces  trabajó para mi.


7
2018-01-19 15:46



He visto lo mismo en Visual Studio 2013 y 2015 CTP.

Ninguna de las soluciones anteriores funcionó, pero reiniciar Visual Studio sí (después de mostrar la advertencia a continuación).

enter image description here


7
2018-04-03 07:50



Algo que funcionó para mí:

Tratar Tools > Import and Export Settings... entonces solo selecciona Keyboard.

Buscar Bkspce y ver si se usa para cualquier cosa.

Accidentalmente tuve algo vinculado a Global Bkspce, Bkspce que causó un problema muy extraño.


2
2017-07-25 18:20



Esto me pasó cuando instalé ReSharper a un Visual Studio que tiene VsVim instalado, y lo solucioné haciendo lo siguiente:

  1. Desinstalar VsVim
  2. Restablezca la asignación del teclado a la predeterminada en Tools -> Options -> Environment -> Keyboard
  3. Selecciona el ReSharper mapeo de atajos de teclado en ReSharper opciones. (Yo suelo ReSharper 2.x or IntelliJ IDEA), y asegúrese Enter, Backspacetrabajo, etc.
  4. Instalar VsVim y configura sus opciones de teclado.

1
2018-01-17 19:45



Resharper podría ser la razón. Ninguna de las soluciones anteriores funcionó para mí. Primero compruebe si Resharper es el problema.

Simplemente vaya a Herramientas> Opciones> ReSharper> General> Haga clic en suspender Resharper.

Después de seguir los pasos anteriores, si funciona ahora como se esperaba, su problema podría deberse a la caché.

Borrar caché seguido de la navegación a continuación.

Resharper> Opciones> General> Borrar cachés o borrarlos a mano

O puede haber un problema al no coincidir las etiquetas de script en el cshtml. (Raro, pero fue el caso el que causa mi problema)


0
2017-08-17 11:19