Pregunta Android studio 2.3 refrescante proyecto de gradle para siempre


Actualicé mi estudio de Android a la nueva versión 2.3 y me pidieron que convirtiera mi proyecto para que coincidiera con los nuevos formatos que hice. También me pidieron que actualizara la versión gradle y lo hice. Ahora, una eternidad más tarde, sigue refrescando mi proyecto gradle. Lo he reiniciado varias veces y tengo conexión a Internet activa. Alguna sugerencia


11
2018-03-03 14:54


origen


Respuestas:


Depende a veces de lo que estás construyendo. Como dijo Hamid, es algo que se debe hacer sin conexión, reduce mucho los tiempos, o al menos no hace mucho tiempo.

También compruebe que no está creando API de Google que no está utilizando, tenga cuidado con los servicios de juego o mapas de Google, a veces toman mucho tiempo y quizás no los esté usando.

Si esa es una opción, instale Android Studio en un SSD, no compre uno, pero si lo tiene, considere moverlo, redujo mi gradle en un 90%.

Además, verifique esta, un poco viejo, pero puede ayudar.


3
2018-03-04 21:10



Este método funciona para Mí:

Cambiar la ruta de inicio de Gradle como C: \ Archivos de programa \ Android \ Android Studio \ gradle \ gradle-3.2

Para abrir la configuración de inicio de Gradle:

Settings->Build,Execution,Deployment->Gradle->Gradle Home

Screen Shot


5
2018-03-07 09:33



Podría ser causado por Microsoft Defender. Compruebe si msmpeng.exe se está ejecutando en el administrador de tareas y excluir el directorio de Android.


2
2018-03-05 17:02



Usar el envoltorio gradle predeterminado y desconectarme de mi red corporativa a una red 4G resolvió mi problema


1
2018-03-07 11:32



File> Settings> Build, Execution, Deployment> Gradle> y verifique el trabajo sin conexión


0
2018-03-03 16:37



Si tiene un error para Sync Gradle. Como; La sincronización de Gradle falló: la versión de Gradle soportada mínima es 3.3. La versión actual es 3.2.

  1. Descargue la versión compatible Gradle manualmente.
  2. Desmarque "Usar envoltorio de gradle predeterminado (recomendado)"
  3. Marque "Usar distribución de gradle local" y configure la ruta de inicio de Gradle.
  4. Verifica el trabajo fuera de línea.

0
2018-03-16 23:43



Actualizando la ruta gradle en

Archivo> Configuraciones> Compilación, Ejecución, Despliegue> Gradle

trabajó para mi. El problema ocurrió después de actualizar Android Studio.


0
2017-10-14 11:40