Pregunta Problemas para iniciar tomcatv7 a través de Eclipse Kepler


Veo que problemas como el mío han sido publicados anteriormente, algunos de los cuales fueron respondidos. He intentado las correcciones, que de hecho parece que deberían haber funcionado, pero todavía me encuentro con el mismo problema:

Estoy intentando ejecutar un proyecto web dinámico en Eclipse Kepler (Java EE) a través de apache tomcat 7.0.53 en mi servidor local. Creé Tomcat como servidor en Eclipse y copié los archivos de configuración de /tomcat/7.0.53/libexec/conf en / workspace / Servers / Tomcat v7.0 Server en localhost-config, y cambié los permisos en los archivos para que todos sean legibles y escribibles.

Sin embargo, cuando trato de iniciar el servidor Tomcat en Eclipse, aparece este error:

No se pudo cargar la configuración del servidor Tomcat en / Servers / Tomcat v7.0 Server en localhost-config. La configuración puede estar corrupta o incompleta.

En caso de que sea útil, todo se ejecuta en mac osx 10.6.8, en una máquina de 64 bits.

Gracias de antemano por tu ayuda.


10
2018-04-11 04:38


origen


Respuestas:


Estoy enfrentando este problema. Lo he arreglado de la siguiente manera,

Paso 1: Eliminar el servidor en el host local (pestaña Servidor)

Paso 2: carpeta Eliminar servidores en (navegador / explorador de proyectos)

Paso 3: después de agregar Nuevo-> servidor-> Apache-> elegir ruta

Paso 4: inicia el servidor

Después de que funcione ...


33
2017-12-22 17:21



Cómo resolver:

1. Cerrar Eclipse

2. Copie todos los archivos de TOMCAT_7_HOME / conf en WORKSPACE_FOLDER / Servers / Tomcat v7.0.53 Servidor en localhost-config

3.Iniciar Eclipse

4. Amplíe el proyecto Servidores, haga clic en el proyecto Tomcat 7 y presione F5

5. Inicia Tomcat desde Eclipse


4
2018-02-19 21:04



Vaya a Servidor -> Apache Tomcat v7.0 -> Agregar Seleccione jre7 en lugar de JRE predeterminado de Workbench Haga clic en Finalizar Detener el servidor y luego iniciar el servidor


2
2017-09-17 11:16



Esto es un problema de permisos (Tuve el mismo problema en ubuntu 14.04, eclipse luna, tomcat7). Los archivos ejecutables no están marcados como "ejecutables" cuando tomcat se descarga de eclipse.

Simplemente vaya a su directorio "[tomcat] / bin" en su sistema de archivos y agregar permiso de ejecución (x) a todos los archivos .sh. A continuación, vuelva a la pestaña eclipse / servers, elimine la entrada tomcat7 y cree otra vez, finalmente inicie tomcat from eclipse.


1
2018-02-09 16:31



Me pasó el mismo problema antes de que obtuviera una solución para el error de carga de configuración:

se puede resolver Haga clic derecho en Proyecto-> Crear ruta-> Configurar ruta de compilación-> vaya a la pestaña Biblioteca-> Agregar jar externo-> explore (Carpeta de Apache TomCat-> lib-> y agregue servlet-api.jar) agregue haga clic en Aceptar . funciona bien para mí.


0
2018-04-11 04:47



Desafortunadamente, esto no es una gran respuesta. Finalmente, nunca funcionó esto con el eclipse Kepler. Sin embargo, cuando instalé Linux mint en mi computadora, y usé su instalador de software para instalar Linux 3.8 (índigo), agregué todas las actualizaciones de EE (todas las adiciones de web / xml a través de ayuda -> instalar nuevo software -> sitio de actualización índigo ), instalé tomcat 7.0, finalmente obtuve eclipse para jugar bien con tomcat (es decir, puedo ejecutar la aplicación web en tomcat desde eclipse, sin copiar / pegar todos los archivos requeridos en tomcat, lo que me está ahorrando un montón de tiempo).

Estoy seguro de que hay una mejor manera de hacerlo: si alguien tiene alguna idea sobre lo que pudo haber salido mal en mi entorno inicial, avíseme. Tengo curiosidad por saber por qué no funcionó. Aquí estaban las especificaciones:

MacOS 10.6.8 Eclipse 4.3.2 Tomcat 7.0.54

Mis disculpas, Raju, por no responder antes. Gracias por tu publicación.


0
2018-06-10 22:00



Cómo resolver:

Cerrar Eclipse Copie todos los archivos de TOMCAT_7_HOME / conf en WORKSPACE_FOLDER / Servers / Tomcat v7.0 Server en localhost-config Comience Eclipse Expanda el proyecto Servidores, haga clic en el proyecto Tomcat 7 y presione F5 Inicie Tomcat desde Eclipse


0
2017-12-18 06:36



Descubrí que este es un buen problema para convenciones de nomenclatura de directorios de moda. Estoy ejecutando Linux Ubuntu y noté que justo debajo de {your work space} / Servers apareció un extraño archivo de tipo de error cuando lo abrí tenía todo tipo de fragmentos del loco y largo nombre de directorio "Tomcat 7.0 Server ... bla bla" Así que eliminé el Servidor, luego hice uso de este pequeño ditty porque mi versión tampoco me permite volver a agregar el servidor:  1. Cerrar Eclipse  2. En {workspace-directory} /. Metadata / .plugins / org.eclipse.core.runtime / .settings, elimine los siguientes dos archivos: org.eclipse.wst.server.core.prefs org.eclipse.jst.server.tomcat.core.prefs  3. Reinicie Eclipse

Luego volví a agregar el servidor usando un nombre de servidor más amigable sin espacios locos o chars: Tomcat7ServerAtLocalHost

El wella ... comenzó con un nuevo error para mí para depurar ... lo que significa que estoy en el camino correcto ... Por cierto, el nuevo error es: "No se puede publicar en el servidor porque le falta su tiempo de ejecución ambiente."

Así que me voy a depurar ese desastre ... ¡Salud!


0
2018-05-16 22:05



Este problema se asocia principalmente con permisos de archivos. Entonces, la mejor manera de resolver el problema es instalar una copia local de Tomcat en su máquina de desarrollo en lugar de poner a Tomcat en un directorio de sistema como /usr/share/tomcat7. De esta forma, todos los archivos conf de Tomcat pertenecen al usuario y grupo de usuarios para que el usuario pueda ejecutarlos desde Eclipse. Normalmente coloco Tomcat en mi carpeta local, como /home/abc/dev y funciona perfectamente con el entorno de desarrollo Eclipse.


0
2017-07-14 17:37



Para mí, la única solución que funciona es esta solución que se sugiere aquí: No se pudo cargar la configuración del servidor Tomcat

cd /usr/share/tomcat7
sudo ln -s /var/lib/tomcat7/conf conf
sudo ln -s /var/log/tomcat7 log
sudo ln -s /etc/tomcat7/policy.d/03catalina.policy conf/catalina.policy
sudo chmod -R a+rwx /usr/share/tomcat7/conf

0
2018-03-01 10:48