Pregunta Simple C # Editor en Visual Studio 2012 (sin intellisense, sin indentación, sin resaltado de código)


Acabo de instalar Visual Studio 2012 en mi máquina, anteriormente tuve Visual Studio 2012 RC que desinstalé antes. La instalación fue exitosa, pero después de abrir un proyecto, el editor C # no funciona, es como un editor de texto simple como este:

C# editor

Intenté repararlo, desinstalarlo por completo y luego volver a instalarlo, pero no tuve éxito.

¿Alguien tiene una idea?

No sé si está relacionado, pero también estoy recibiendo este error a veces al crear un nuevo proyecto o al abrir uno existente:

Vs error

Gracias por adelantado


55
2017-08-16 13:19


origen


Respuestas:


Estoy bastante seguro de que el error sobre ManagedObjectFactory está relacionado con los síntomas que está describiendo. Este error indica que su instalación de Visual Studio (particularmente el servicio de lenguaje C #) está dañada. Lo más probable es que esto se deba a algún problema de configuración, que estamos trabajando actualmente para identificar.

Tuve la oportunidad de investigar este error y descubrí que uno de nuestros ensambles de interoperabilidad se instaló inesperadamente en el GAC, mientras que no debería ser así. Está instalado en el GAC por el instalador de Windows, lo que indica que se trata de un problema de instalación. La solución es desinstalarlo del GAC, pero como está instalado por el instalador de Windows, es más que simplemente "gacutil / u". Debe seguir el procedimiento descrito en KB873195 para eliminarlo del GAC:

  1. Elimine un valor correspondiente al "Microsoft.VisualStudio.CSharp.Services.Language".Interop"Ensamblado desde" HKLM \ SOFTWARE \ Classes \ Installer \ Assemblies \ Global \ ". Tenga en cuenta la parte "Interop" porque también hay un ensamblado Microsoft.VisualStudio.CSharp.Services.Language, que debe estar en el GAC.
  2. Inicie el "Símbolo del sistema de herramientas nativas VS2012 x86" y ejecute "gacutil / u Microsoft.VisualStudio.CSharp.Services.Language.Interop".

Descargo de responsabilidad: soy un desarrollador en el equipo Visual Studio C # IDE.


85
2017-08-20 18:04



Es posible que algunas de las configuraciones estén deshabilitadas en Visual Studio. Verifique la siguiente configuración:

Tools->Options->Text Editor->C#->General->Auto list members
Tools->Options->Text Editor->C#->General->Parameter information

EDITAR:

También verifica

Tools->Options->Text Editor->C#->Intellisense->
Show completion list after a character is typed

Aquí hay un artículo en el blog de ScottGu que puede ser útil: D

Segundo EDIT:

Hay un artículo más en el blog de ScottGu titulado Sin Intellisense con VS 2010 RC (y cómo solucionarlo). Avísame si eso ayuda. los el parche está disponible aquí.

Tercera edición:

Tools –> Import and Export Settings ->  Reset all Settings

Puede hacer una copia de seguridad de la configuración anterior si lo desea. Esta solución es para visual studio 2012. Creo que esto debería funcionar

Cuarta Edición: En lugar de cambiarlo solo por C #, cámbielo por todos los idiomas

Tools > Options > Text Editor > All Languages

En general, asegúrese de que las casillas de verificación en la sección Finalización de estado de cuenta estén activadas (no atenuadas). Existe la posibilidad de tener un cuadrado azul en lugar de una marca. Como las casillas de verificación son 3 estados, el cuadrado significaba que la "Selección parcial" estaba en efecto. Una vez que la marca esté en vigencia, reinicie Visual Studio y vuelva a intentarlo.

Edición final:

Parece que a la instalación le faltan algunos archivos. Le aconsejo que descargue una copia nueva del software e instálela desde cero, con la configuración predeterminada activa.


7
2017-08-16 13:25



Acabo de tener el mismo problema que tú y seguí las instrucciones que encontré aquí.

La parte que encontré que funcionó fue:

  1. Intente ejecutar devenv / Resetsettings en Símbolo del sistema para eliminar la causa de las configuraciones dañadas.
  2. Intenta ejecutar devenv / ResetSkipPkgs en Símbolo del sistema.
  3. Intente ejecutar devenv / Safemode en el símbolo del sistema para ver si puede aplicarlo correctamente.
  4. Intente ejecutar devenv / Resetuserdata en el símbolo del sistema para restablecer todo su entorno VS y la configuración de personalización.

6
2017-08-16 13:30



Prueba a eliminar:

  • % appdata% \ Roaming \ Microsoft \ Microsoft Visual Studio
  • % appdata% \ Roaming \ Microsoft \ VisualStudio
  • % appdata% \ Local \ Microsoft \ VisualStudio

Esto debería borrar todas las configuraciones de su estudio visual (de todas las versiones) y restaurarlas a sus valores predeterminados, en caso de que el RC haya dejado algunas configuraciones antiguas que no le gustan a la RTM.

Editar:

También quieres eliminar

  • Mis documentos / Visual Studio 2012 / Configuración

3
2017-08-16 13:27



Si tiene vs2012 instalado en otro disco (por ejemplo, el disco D :) que el RC (instalado en el disco E :), intente copiar E:\Program Files\Micosoft Visual Studio 11 a la carpeta correspondiente en D :.


1
2017-08-16 13:35



Si tienes una versión RC, podría ser la causa.

Tuve este problema con Visual Studio 2012 Developer Edition. Más tarde descubrí que tengo Express Edition RC, lo eliminé y resolvió el problema.

Y luego apliqué la solución de eggie


1
2017-09-14 15:05



Bueno, todavía no sé cuál era el problema, pero lo resolví desinstalando Visual Studio 2012 final, luego instalando Visual Studio 2012 RC, y luego, sin desinstalar RC, instalé de nuevo la versión final.

Gracias a todos por su ayuda.


0
2017-08-17 02:41



Ni la solución de Oleg (ni las variaciones sugeridas en los comentarios) ni el estudio Repairing Visual funcionaron para mí. Finalmente apreté una solución que se muestra aquí 

Entonces 3 sencillos pasos:

1) Cierre todas las instancias de Visual Studio

2) ejecutar Developer Command Prompt for VS2012 (buscar en el menú Inicio) como administrador

3) Luego escribe devenv.exe /setup

Eso lo hizo por mí.


0
2018-05-16 21:24